2011年12月05日

NEC IXルータでL2ブリッジ設定

IXルータ−WAN−IXルータ
の環境でブリッジ接続を行う設定例。
WAN側はIPv6を固定で割り当てられてていることにしてみた。

ip ufs-cache enable
ipv6 ufs-cache enable
ipv6 route default 2001:****:****::1
bridge irb enable

interface FastEthernet0/1.0
no ip address
ipv6 address 2001:****:****::2/64
no shutdown

interface FastEthernet1/0.0
ip address 10.10.10.52/24
bridge-group 1
no shutdown

interface BRI1/0.0
encapsulation ppp
no auto-connect
no ip address
shutdown


LAN側のIP設定は必要ないが、メンテ用に設定。
これを双方にアドレス設定すればブリッジとして動作したよ。


posted by @yamaju_chige at 15:38| Comment(1) | ネットワーク | このブログの読者になる | 更新情報をチェックする

2011年07月19日

NATの外側アドレスをOSPFで流したい(YAMAHA RTX)

私はYAMAHAルータがメインなんだけど、これ、Tunnel内でNATが掛けられる。
で、このTunnel内NATを行った際にOSPFと一緒に使うとNATアドレスに対する経路の広告ができないという問題に直面する。
NATだからインタフェースを持っていないし当然といえば当然か。
で、どうするか。LoopBackアドレスを使いましょうということになるけど・・・
9個までしか定義できない上、/24でネットワーク指定しても/32のIP毎でしか経路通知ができない!

これは仕様だから仕方ないか。
そもそもTunnel内NATとOSPFを一緒に使うのが誤り。
いやいや。NAT自体が誤り。でもどうしようもないのよね。IP帯域重複しているようなところは。

あと、1台のRTXから1本以上のTunnelを作成してOSPFで経路制御しようとるすと、Costだけが変化してインタフェースが変化しない。結果うまく経路切り替えが行われないって事も発生。
これは、Tunnelインタフェースのアドレスを明示してやればおk。

tunnel select 1
ip tunnel address 1.1.1.1
ip tunnel remote address 1.1.1.2

このようにTunnelのローカル/リモートを明示するとOSPFの経路情報に表示されうまく切り替わるようになった。

posted by @yamaju_chige at 10:56| Comment(0) | ネットワーク | このブログの読者になる | 更新情報をチェックする

2011年07月08日

【解決】NATを使った場合のOSPF経路制御

自分でもやってはみたんだけど、惜しかった!
NATのアドレスをLoopbackアドレスに登録してOSPFで流すという方法。
これでOSPFで広告する事ができた。

Loopbackに登録するところまではやったのにOSPF BackBone設定を忘れてたw
posted by @yamaju_chige at 16:24| Comment(0) | ネットワーク | このブログの読者になる | 更新情報をチェックする

広告


この広告は60日以上更新がないブログに表示がされております。

以下のいずれかの方法で非表示にすることが可能です。

・記事の投稿、編集をおこなう
・マイブログの【設定】 > 【広告設定】 より、「60日間更新が無い場合」 の 「広告を表示しない」にチェックを入れて保存する。


×

この広告は180日以上新しい記事の投稿がないブログに表示されております。